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V9R5 What’s New 

Professional 

Active/Inactive of Body and Group 

Product Professional, FFlex, RFlex 

New/Improved Improved 

Location in User Interface Database pop-up menu, Working Window pop-up menu, Properties 

Dialog box → General tab 

Location in Manual User Interface → RecurDyn Graphic User Interface → Database 

Window → Active/Inactive 

 

 

Active/Inactive status can be switched for Bodies (Rigid, FFlex, RFlex) and Groups. In addition, 

the entities (Joints, Forces, Contacts) connected to the Body are automatically switched to 

active/inactive along with the Body. A Body or Group changed to Inactive is not considered in the 

calculation during the simulation. 

⚫ Active/Inactive of Body: You can switch the Active/Inactive status from the Body’s 

Properties window, pop-up menu in the database, and pop-up menu of the working 

window. 

 

Description 
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⚫ Activate Related Entities Together: This option is 

available from the right-click menu on the Inactive 

Body. When selecting this option, the Body is switched 

to the Active status, and at the same time, the entities 

connected to this Body are also switched to the Active 

status. (If you deselect the Inactive option from the 

pop-up menu, the entities connected to the Body do 

not switch to the Active status) 

 

⚫ Active/Inactive of Group: A General Group or a Toolkit’s Group can switch Active/Inactive 

status through the Update Inactive Flag of All Entities option in the corresponding 

Properties dialog box. 

 

 

  



 

- 5 - 

 

V9R5 What’s New 

⚫ Graphic changes of Inactive status: The Inactive entities are changed to the colors specified 

in [Home tab]-[Setting group]-[Display]-[Geometry tab]-[Color of an Inactivated Entity] 

and the wireframes are changed to dotted lines. In the database, the icons of the Inactive 

entities are changed accordingly. 

 

 

 

It is now possible to exclude Bodies from a simulation by simply making them Inactive without 

deleting them. If necessary, Gear Box, FFlex Body, etc. can also be made Inactive and simulated to 

enable efficient analysis. 

 

  

Benefits 



 

- 6 - 

 

V9R5 What’s New 

Eigenvalue Analysis Enhancement 

Product Professional 

New/Improved Improved 

Location in User Interface Analysis tab → Simulation Type group → Eigen icon 

Location in Manual Analysis → Eigen (Eigenvalue) → Property → Parameter tab 

 

 

In Eigenvalue Analysis, it is now possible to not record frequencies lower than the ones specified 

by the user in the analysis result file. 

⚫ Cutoff Lower Frequency [Hz]: Results for frequencies lower than the ones specified by the 

user are not recorded in the analysis result file. 

 

 

 

The result file size can be reduced by not writing low frequency results in the file which are 

unnecessary when analyzing the results. 

 

  

Description 

Benefits 
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On/Off in CMotion Group 

Product Professional 

New/Improved Improved 

Location in User Interface Professional tab → Joint group → CMotion(G) icon 

Location in Manual Professional → Joint → Primitive Joints → Cartesian Motion Group 

(CMotion Group) → Properties 

 

 

In CMotion Group, it is now possible to select an expression to define the On/Off of Motion 

according to the conditions specified by the user for each degree of freedom. Motions for all six 

degrees of freedom can be turned On/Off under one condition, or the On/Off conditions can be 

individually defined for each degree of freedom. 

 

 

 

CMotion with various degrees of freedom and On/Off conditions make it easy and simple to 

express motions that vary depending on the conditions.  

Description 

Benefits 
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Newly Added DOE Analysis 

Product Professional 

New/Improved New 

Location in User Interface Analysis tab → Simulation Type group → DOE icon 

Location in Manual Analysis → DOE (Design Of Experiments) 

 

 

DOE (Design of Experiments) Analysis has been newly added to provide a variety of new functions. 

In addition, improvements to Design Variables and Performance Indices further enable design 

studies based upon DOE. DOE Analysis consists of 4 tabs representing each step in the analysis 

process. 

⚫ Design Variable: It is now possible to view the parameter list defined in Design Variable 

(DV) of SubEntity. In addition, 6 DOE methods are provided to generate the DOE Table. 

  

Description 
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⚫ Performance Index: SubEntity's Performance Index (PI) list is displayed. 

 

⚫ Simulation: This tab allows the user to modify the basic simulation parameters and change 

the simulation options related to DOE Analysis. DOE analysis is performed by clicking the 

Simulation button and supports the Standalone Solver. 
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⚫ Result Sheet: It is now possible to view the results of each trial for DOE analysis in various 

graphs. Analysis results can be exported in CSV file format and analysis models of selected 

trials can also be saved. 

– Update Current Model: The current model is updated with the parameters of the 

selected trial. 

– Create New Model: The model to which the design variables of the selected trial are 

applied is saved as a new model. 
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⚫ Improved Design Variable in SubEntity: The Design Variable List dialog box has been 

improved to display the detailed settings of various Design Variables. 

 

⚫ Improved SubEntity Performance Index: The Performance Index List dialog box has been 

improved. In addition to the existing Expression types, it is now possible to define 

Performance Index using Scope and ProcessNet types. 

 

 

 

With the newly added DOE (Design of Experiments) Analysis, it is now possible to perform a 

more advanced design study based on the DOE method suitable for the user-selected system. 6 

DOE methods are provided to allow you to create a more optimized DOE Table for the selected 

system to be analyzed. In addition, through the improved Performance Index, the performance 

evaluation of the system based on the design variables can be more specifically quantified, allowing 

you to quickly make design changes to improve the system performance. 

 

  

Benefits 
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ProcessNet's Python Support 

Product Professional 

New/Improved New 

Location in User Interface Customize tab → ProcessNet (Python) group 

Location in Manual ProcessNet Help → Python 

 

 

ProcessNet, which provides various RecurDyn API, now supports Python. This makes it possible 

to develop various customized functions using Python in RecurDyn. 

 

⚫ ProcessNet Settings: You can select Python from ProcessNet Type in [Home tab]-[Setting 

group]-[ProcessNet]. 

 

– Pre/Post Simulation: Python Script can be registered in Pre/Post Simulation in the same 

way as the existing C# DLL 

– External IDE: Users can specify their own preferred Python IDE. 

  

Description 
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⚫ Support for Python ProcessNet in Analysis Response of AutoDesign: You can select Python 

from ProcessNet Type in Analysis Response in [AutoDesign]-[Parameter]-[Response]. 

 

 

 

The addition of Python to ProcessNet makes it possible to develop automation scripts for 

repetitive tasks, user-customized UIs, utilities for improved convenience, and toolkits of new 

concepts with easier and simpler programming. In addition, various Python libraries are available 

for ProcessNet. 

 

  

Benefits 
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Marker Trace Enhancements 

Product Professional 

New/Improved Improved 

Location in User Interface Analysis tab → Post Tool group → Trace icon 

Location in Manual Analysis → Post Tool → Marker Trace 

 

 

It is possible to view the trajectory of markers belonging to a subsystem in the Assembly mode. 

In addition, the trajectory of the marker can be displayed based on a specified Reference Marker, 

allowing the user to check the relative movement of the body through the Marker Trace. 

 

 

  

Description 
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UV Surface Creation 

Product Professional 

New/Improved New 

Location in User Interface Body Edit Mode → Geometry tab → Surface group → UV icon 

Location in Manual Professional → Body → Geometries in Body Edit Mode → Surface → 

UV Surface 

 

 

It is now possible for users to create their own UV Surfaces used for UV Sphere Contact and PTSF 

(Point to Surface) joints. The UV Surface function, added to the Surface group in Geometry Edit 

Mode, allows the user to create a 4-sided UV surface based on a surface selected by the user. The 

UV Surface created through this function can be utilized for UV Sphere Contacts and PTSF (Point 

to Surface) joints. 

 

⚫ 4-Sided Edges Group: Defines a UV Surface by specifying the 1st and 3rd Edge groups out 

of a total of 4 Edge Groups. Even a surface with more than 4 edges can be used to create 

a UV surface by defining the Edge Group. 

⚫ Fill Holes: If there are holes in the target surface, the UV surface cannot be created. This 

function allows the user to remove holes and create a UV surface. 

 

  

Description 
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Cyclic Spline 

Product Professional 

New/Improved Improved 

Location in User Interface SubEntity tab → Expression group → Spline icon → Viewer 

Location in Manual Subentity → Spline → Step to create a spline → Using Spline Viewer 

dialog 

 

 

A Cyclic option has been added to the Extrapolation Type field in the Spline SubEntity. It is now 

possible to easily create periodic splines by selecting the Cyclic Expression Type in Spline. This 

function can be useful for periodic input signals or repetitive motions. 

 

Description 
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Kinetic Energy, Potential Energy, Strain Energy 

Product Professional 

New/Improved Improved 

Location in User Interface Analysis tab → Plot group → Result icon 

Location in Manual Plot → Plot Database 

 

 

It is now possible to view the numerical results of Kinetic Energy, Potential Energy, and Strain 

Energy for a body in the Plot. 

 

⚫ Items Supported in Plot Database 

– Rigid Body: Kinetic Energy, Potential Energy 

– RFlex Body: Kinetic Energy, Potential Energy, Strain Energy 

– FFlex Body: Kinetic Energy, Potential Energy, Strain Energy 

Description 
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Campbell Diagram 3D Enhancements 

Product Professional 

New/Improved Improved 

Location in User Interface Plot > Tool > Analysis > Campbell (3D) 

Location in Manual Plot > Tool > Analysis > Campbell Diagrams > Vold-Kalman Filter 

 

 

When using Campbell Diagram, it is now possible to more accurately calculate the RPM-

Magnitude provided in Section View by using a Vold-Kalman Filter. In addition, the phase angle 

that can be used for vibration analysis is also displayed in the Section View. 

⚫ Results using the Vold-Kalman Filter (available only when using the RPM-Order option) 

 

 

  

Description 
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EXPVAL() function referring to Expression 

Product MTT2D, MTT3D 

New/Improved Improved 

Location in User Interface MTT2D/3D tab → Sensor group → Event icon 

Location in Manual Toolkit > MTT2D → Specific Sensors → Event Sensor → Properties 

 

 

The EXPVAL() function has been added to Expression. This function directly refers to another 

Expression and returns a result. Through EXPVAL(), it is now possible to define an Expression that 

adopts the values of another Expression. For example, when Expression1 and Expression2 are both 

defined as shown in the figure below, it allows the user to define a new Expression3 that has added 

the two expressions. 

 

Note) 

Circular references through EXPVAL() are not allowed due to the characteristics of Expression. 

Ex) Expression1 = EXPVAL(Expression2), Expression2 = EXPVAL(Expression1) 

  

Description 
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RecurDyn XML File (*.rdx) 

Product Professional 

New/Improved New 

Location in User Interface - 

Location in Manual User Interface → RecurDyn Graphic User Interface → File Menu → 

Import → RecurDyn Files 

 

 

RecurDyn model files can be now saved in text format (XML format). The extension of model 

files in text format is *.rdx and can be saved or imported through Import and Export. Depending 

on the model, information is divided and saved in several other files such as those shown in the 

image below. For more detailed information on each file, refer to the manual. 

 

 

  

Description 
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UI Convenience Enhancements 

Product Professional, FFlex 

New/Improved Improved 

Location in User Interface - 

Location in Manual - 

 

 

Various features have been improved for better UI convenience. 

⚫ Modeling 

– Improved ‘Use Detailed Info’ in Database Settings: You can adjust the number of 

displayed digits in parametric values and parametric point values through the ‘Use 

Detailed Info’ function of the Database Settings. The Display Digit Number setting is 

found in the Database Settings dialog box accessible through [Home]–[Settings]–

[Database]. Up to 15 digits can be displayed 

      

  

Description 



 

- 22 - 

 

V9R5 What’s New 

– Node Preview: When creating a node, it is now possible to preview the location of the 

node to be created. The node location specified by user will be shown in the Working 

Window. In particular, Node Previews are useful when creating a node using the 2-

Nodes and 3-Nodes creation methods. 

 

⚫ Post-Processing 

– Active/Inactive Force Display: The Use option has been added to the Force Display 

dialog box accessible through [Analysis]–[Post Tool]–[Display]. When the Use option is 

turned off, the Force Display for this entity is not shown in the Working Window. 

 

– Reference change in Animation Scaling dialog box: It is now possible to change the 

Reference Marker in the Animation Scaling dialog box. 

 



 

- 23 - 

 

V9R5 What’s New 

– Contour Min/Max Value Display Improvement: When displaying the min/max values 

by checking the Show Min/Max option in Contour, it is sometimes difficult to view 

these values because the minimum and maximum values are overlapped on the screen. 

It is now possible to set whether to display Min or Max respectively. 
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MFBD 

Vibration Shape 

Product FFlex, RFlex 

New/Improved New 

Location in User Interface Post Analysis tab → Vibration Shape group 

Location in Manual Post Analysis → Vibration Shape 

 

 

After an MFBD simulation, it is now possible to view the vibration shape of the flexible body from 

the results of the dynamic behavior of an FFlex body. This allows you to analyze the vibration 

characteristics, the vibration frequency and the vibration shape of the FFlex body in motion. You 

can select the PatchSet of the target FFlex body and calculate the vibration shape to obtain the 

vibration frequency and its vibration shape results. 

 

⚫ Vibration Shape Calculation 

 

Description 
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– Sampling Frequency: To perform FFT, the displacement information of nodes with a 

constant time interval is required. This data is generated through interpolation using 

the specified sampling frequency. (default: 1000Hz, 1000 data points generated per 

second through interpolation) 

– Calculation: FFT calculates the frequency and vibration shape data based on the 

displacement information of the nodes included in the user-defined PatchSet. After 

the calculation is completed, a VSD file (*.vsd, vibration shape data) is generated with 

the name specified in the Base Name of the results. 

⚫ Vibration Shape Animation 

  

– Frequency: You can view the results of the vibration shape calculation by clicking the 

button […] under the Frequency category. This allows you to check the absolute value 

and phase angle for each frequency and select the frequency to view using animation. 

– Make Animation: A Vibration Shape Animation is created with the specified animation 

settings. 

– Export: You can save the data related to the vibration shape such as node position, 

absolute value, and phase angle for each animation frame in a CSV file format. 

– Play: Vibration Shape Animation which is created through Make Animation is played. 

 

 

Vibration Shape allows you to analyze the vibration characteristics of a system in detail. In 

particular, it is now possible to predict the impact of the vibration shape on the behavior of a 

specific part. 

 

Benefits 
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Node Constraint 

Product FFlex 

New/Improved New 

Location in User Interface Flexible tab → FFlex group → N.Con icon 

Location in Manual  

 

 

With the Node Constraint function newly added to FFlex, it is now possible to easily connect two 

FFlex bodies with Rigid Type FDR. The first step is to create a node set at the junctions of each of 

the two FFlex bodies to be connected. The Node Constraint function then allows you to easily 

constrain two FFlex bodies with Rigid Type FDR simply by specifying the two pre-created node sets. 

 

 

⚫ Features of Node Constraint 

– No need for additional meshing 

– Different types of elements can be connected such as a connection between Solid4 

and Shell4. 

– Different sizes of elements can be connected. 

 

 

Two FFlex bodies can be connected without any element type or size restrictions and without the 

need for any additional meshing. Even if it was impossible to combine two FFlex bodies through 

the Flex Merge function, it is now possible to easily combine them using Node Constraint. The node 

constraint keeps each FFlex body separate. On the other hand, Flex Merge creates one new FFlex 

Body that combines the two bodies. 

 

 

Description 

Benefits 
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FFlex Thermal Enhancement 

Product FFlex 

New/Improved Improved 

Location in User Interface Flexible tab → FFlex group → Convection icon 

Location in Manual Flexible → FFlex → Structural analysis with Heat Transfer → 

Convection 

 

 

The Convection function, one of the FFlex Thermal features, has been improved which enables 

the application of thermal stress due to convection on the surface of a flexible body. RTL (RecurDyn 

Temperature Load) files can be used to define surface heat transfer rates that change over time. 

⚫ Set Variable Value: When this option is selected, 

the input parameters related to the RTL file in the 

Heat Transfer Coefficient (HTC) and Ambient 

Fluid Temperature (AFT) are activated. 

 

⚫ Support for OBJ file export: To synchronize the 

HTC and AFT information of each node 

simulated by thermal/fluid analysis software with 

the nodes of a RecurDyn FFlex Body, both 

software must use the same FE Mesh. The OBJ 

file export function has been added to the 

Export Shell Data of FFlex Edit Mode. 

  

 

  

Description 
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⚫ RTL Converter: Particleworks can save HTC and AFT results for each node including the 

information of specified time and step interval in CSV file format. A converter is provided 

to easily convert this CSV result file to an RTL file for use in RecurDyn. This converter is 

offered through an Excel macro document called 'RTLGenwithExcel.xlsm' in <RecurDyn 

Install Path>\Bin\Utility. (Please refer to the manual for detailed information of 

RTLGenwithExcel.xlsm) 

 

 

In CFD software such as Particleworks, it is now possible to perform thermal/fluid analysis to 

obtain the heat transfer coefficient (HTC) and ambient fluid temperature (AFT) results at the surface 

nodes of a mechanical system. These results can be applied in RecurDyn for MFBD analysis that 

considers the conduction within a  flexible body as well as the convection with the surrounding 

fluid. From these results, it is now possible to analyze not only the fluid behavior between the 

flexible body and fluid, but also the effects of heat transfer between the mechanical system and 

surrounding fluid. For example, in analysis of gear dynamics, it is possible to see how high-

temperature gears are cooled by oil. 

 

  

Benefits 



 

- 29 - 

 

V9R5 What’s New 

Mesher Enhancements 

Product Mesher 

New/Improved Improved 

Location in User Interface Mesh Edit Mode → Mesher tab → Mesher group → Adv.Mesh icon, 

BeamMesh icon 

Location in Manual Flexible → Mesher → Meshing Functions in Mesh Mode → Advanced Mesh 

Flexible → Mesher → Meshing Functions in Mesh Mode → Beam Mesh 

 

 

Several improvements in Mesher have been made. In particular, Seed Control has been added to 

Advanced Mesh and the process to create a Beam Mesh has also been improved. 

⚫ Seed Control (Advanced Mesh): It is now possible to directly control the number of Seeds 

on each Edge. This makes it possible to generate high-quality meshes optimized for the 

specific analysis purpose of the current system, such as changing element density or 

creating a uniform pattern. 

 

 

Description 
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⚫ Ignore Vertices (Beam Mesh): When creating a Beam Mesh, it is now possible to decide 

whether to ignore the vertices of the original geometry. If the vertices are ignored, a Beam 

Mesh can be created uniformly with the element size specified by the user. The vertices to 

be ignored can be directly selected while keeping the vertices in the main parts. (This 

function is available in the separate Beam Mesh and is not available in AutoMesh.) 

 

 

 

By using Seed Control of Advanced Mesh and the improved Beam Mesh, high-quality meshes 

can be created which are optimized for the analysis purpose of the current system. 

 

  

Benefits 
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Stress-Strain Curve for Material 

Product FFlex 

New/Improved Improved 

Location in User Interface Flex Edit Mode → Material → Hyperelastic, Plastic 

Location in Manual -  

 

 

A Draw function has been added for the Stress-Strain Relation in the properties of Hyperelastic 

and Plastic material types in FFlex Edit Mode. This makes it possible to view the Stress-Strain curve 

for the material properties entered by the user as a graph. 

 

 

 

If there is experimental data for the material of a flexible body to be used for dynamic analysis, it 

is now possible to compare the Stress-Strain curve for the material properties entered in RecurDyn 

with the experimental data. Including a flexible body with similar properties to real materials in 

dynamics analysis allows the user to obtain more accurate analysis results. 

  

Description 

Benefits 



 

- 32 - 

 

V9R5 What’s New 

RFlex Body Animation Enhancement 

Product RFlex 

New/Improved Improved 

Location in User Interface RFlex Body Properties Dialog → RFlex tab 

Location in Manual Flexible → RFlex → Import RFlex Body → Properties → RFlex Page 

 

 

Out of the modes already included in an RFlex 

Body simulation, you can specify the modes to be 

used for Animation. The modes for Animation can 

be selected from the RFlex tab of the RFlex Body 

Properties dialog box. 

In the image on the right, if all the Animation 

modes are turned off, the animation will play as 

if the existing 'Animation with No Deformation 

Results' option was selected. Therefore, the 

'Animation with No Deformation Results' option 

has been removed. 

 

 

 

By viewing only the animation with specified modes, you can visually check the contribution of 

the corresponding modes (frequencies). In addition, for large RFlex bodies with more than 1000 

modes, the performance of an animation can be improved by including only the specified modes 

in the animation. 

Description 

Benefits 
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RFI Optimizer Enhancement 

Product RFlex 

New/Improved Improved 

Location in User Interface Flexible tab → RFlex group → Optimizer icon 

Location in Manual Flexible → RFlex → RFI Optimizer 

 

 

In the RFI Optimizer, it is now possible to keep only the data in the RFI file that is necessary for 

simulation and delete the rest of the data to reduce the file size. If you select the Update RFI File 

type in the RFI Optimizer, you can directly select the RFlex Body and also the nodes to be maintained 

through the Preserve Nodes option. Only the mesh and shape-related data are kept in the RFI file 

based on the selected nodes, so that the size of the RFI file can be significantly reduced. 

⚫ Preserve Nodes 

– External Nodes: Nodes located on the 

surfaces of an RFlex Body 

– Used Nodes: Nodes referenced in Marker, 

Output, Set, etc. 

– Selected Nodes: Nodes selected by the 

user 

 

 

 

 

 

 

Note) 

– Reduced RFI files cannot be used in G-Manager. 

– Even if the RFlex Body is restored as an original RFI file, the Set information, such as 

PatchSets included in the existing RFlex Body, is not restored. Therefore, it is recommended 

to reduce the RFI file after backing up the RDYN file.  

Description 
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By keeping only the data necessary for simulation in a large RFI file, the file size can be drastically 

reduced without affecting the simulation results. This allows you to experience improved rendering 

and animation performance, reduced size of result file, and improved Stress/Strain Recovery 

performance when modeling. 

 

 

  

Benefits 
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Variable Thickness for Geo Contact 

Product FFlex 

New/Improved Improved 

Location in User Interface Home tab → Setting group → Simulation icon → General tab → 

Advanced Options 

Location in Manual Home → Setting → Simulation → General Tab → Advanced Options 

 

 

In Geo Contact, an analysis can be performed considering the Variable Thickness applied to Shell 

Elements. When performing a contact analysis using Geo Surface Contact, Geo Sphere Contact, or 

Geo Cylinder Contact, the Variable Thickness set in the Shell Element can be considered. To access 

this function, select the Advanced Geo Contact for Shell option in [Home]-[Setting]-[Simulation]-

[Advanced Options]. 

 

  

Description 
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Note) 

- The Thickness of each contact element must be set to Original. 
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Improvements related to RFI file 

Product RFlex 

New/Improved Improved 

Location in User Interface Flexible tab → RFlex group → Optimizer icon, Translator icon 

Location in Manual Flexible → RFlex → RFI Optimizer 

Flexible → RFlex → RFI Translator 

 

 

The functions related to RFI files have been improved. Nastran's anisotropic material, MAT9 is 

supported by Make RFI, RFI Optimizer, and RFlexGen. Other features described below have been 

added. 

⚫ Support for MAT9 in Make RFI: RFI file generation from the Nastran model results 

(*.out/*.op2/*.pch) including Nastran's anisotropic solid material, MAT9 

⚫ RFI Optimizer: DAT and BDF file types have been added for Input Files. 

 

⚫ RFI Translator: Converts an RFI file’s data from binary format 

into text format. This makes it possible to view what 

information is contained in the RFI file as a text file. 

⚫ Additional materials support for RFlexGen: The RFI file can be 

generated using bulk files containing Nastran's MAT2 

(Anisotropic Shell), MAT8 (Orthotropic Shell), and MAT9 

(Anisotropic Solid) materials. 

Description 
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Toolkits 

Improved KISSsoft Gear Train Creation 

Product DriveTrain 

New/Improved Improved 

Location in User Interface DriveTrain tab → KISSsoft group → GearTrain icon 

Location in Manual DriveTrain → Functions for DriveTrain → KISSsoft → Gear Train 

 

 

The improved KISSsoft Gear Train creation method allows you to create various types of gear 

trains. In the previous version, it was only possible to create gear trains connected in sequential 

order as shown in the left figure below. But now you can customize the gear pairs within the gear 

train in any order. 

 
 

RecurDyn V9R4 RecurDyn V9R5 

Gear pairs can only be defined in 

Sequential order 

Various types of gear pairs can be defined 

 

 

 
Ex. Input values for gear pair 

The gear pair on the upper right can be defined using the above input values. 

Description 
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This function allows you to create planetary gears using the Gear Train dialog box including double 

pinion type planetary gears in addition to the existing single pinion type. 

  
Single Pinion Double Pinion 

 

 
<Ex. Input values for double pinion gear> 

  

The double pinion planet gear on the upper right can be defined using the above input values. 

 

 

 

Since it is now possible to model various new types of gear trains, simulations using GearKS can 

be used for various new models such as e-Axle and LSD (Limited-Slip Differential).  

Benefits 
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V9R5 What’s New 

KISSsoft Post 

Product DriveTrain 

New/Improved New 

Location in User Interface DriveTrain tab → KISSsoft group → Post icon  

Location in Manual DriveTrain → Functions for DriveTrain → KISSsoft → Post 

 

 

With the newly added KISSsoft Post, it is now possible to check the various gear pair results listed 

below as a graph or an output data file. 

⚫ Sliding Velocity (SP) 

⚫ Contact Pressure (CP): Hertzian Contact Pressure at the contact point 

⚫ Pressure Velocity (PV): Multiplication of Sliding Velocity and Contact Pressure (SP x CP) 

⚫ Contact Points 

 

 

Description 
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V9R5 What’s New 

Other improvements related to DriveTrain 

Product DriveTrain 

New/Improved Improved 

Location in User Interface DriveTrain tab → KISSsoft UI group → Z14 icon 

Location in Manual DriveTrain → Functions for DriveTrain → KISSsoft → KISSsoft UI 

 

 

Since the KISSsoft built into RecurDyn has been updated to KISSsoft 2020 SP2, you can easily 

take advantage of the improved features of KISSsoft in RecurDyn DriveTrain. 

In addition, KISSsoft's planetary gear module file, Z14, is supported so that planetary gears 

created by KISSsoft can be read in RecurDyn. It is also possible to save planetary gears created in 

RecurDyn as Z14 files, and then read and modify them in KISSsoft. Accordingly, 2 different icon 

buttons that can run KISSsoft within RecurDyn are provided as GearTrain and Planetary Gear 

respectively. 

 

 

Description 
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V9R5 What’s New 

Realistic Surface Rendering 

Product Particleworks Interface 

New/Improved New 

Location in User Interface External SPI tab → Post-Process group → Fluid icon 

Location in Manual External SPI → Functions for External SPI → Post-Process → Fluid 

Display 

 

 

When using the Particleworks Interface, it is now possible to view the flow of fluid particles using 

a more realistic rendering. The newly added Fluid Display function allows you to render the fluid 

particles as a surface that looks similar to the actual fluid. 

 

  

Description 
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V9R5 What’s New 

⚫ Alpha, Threshold: These parameters affect the weight of surrounding particles when 

rendering fluid. The smaller the value is, the more bluntly the fluid is rendered. The initial 

values of these properties are automatically determined based upon the particle size.  

 

⚫ Cell Size: This is the size of the cell used when rendering the fluid. The larger the value is, 

the more bluntly the fluid is rendered, and the initial value is the radius of the particle. 
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V9R5 What’s New 

RecurDyn Post Enhancements 

Product RecurDyn Post 

New/Improved Improved 

Location in User Interface - 

Location in Manual - 

 

 

Various functions have been added to RecurDyn Post since RecurDyn V9R4. 

⚫ Series Information Support: It is now possible to use the upgraded Series Information 

Support in RecurDyn Post which is also provided in Trace Data of RecurDyn/Plot. 

– Min/Max/Average/RMS 

– X, Y change and slope (ΔX, ΔY, ΔY/ΔX) 

– Inflection point display 

– Section setting 

 

 

Description 
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V9R5 What’s New 

⚫ Target and Range 

– Target – Global/Local: If Global is selected, the trace and measurement data for the 

entire range of the curve are calculated. If Local is selected, these data are calculated 

only within the specified X range. 

⚫ Measurement Data 

– Delta (X, Y): ΔX and ΔY are calculated using Xmin (X1, Y1) and Xmax (X2, Y2) within the 

specified X range. 

– Slope: ΔY/ΔX, in other words, the slope of the straight line between (X1, Y1) and (X2, 

Y2) 

⚫ Copy Information: Copy the data in the dialog box to the clipboard and paste them into 

the notepad or other editors. 

⚫ Options: Settings changes such as fonts sizes and colors 

⚫ Copy & Paste of Graph 

– After copying the selected graph using Ctrl+C, it is now possible to easily paste it into 

another document in RecurDyn Post using Ctrl+V. This makes it easy to compare 

graphs from different documents in one document. 

– As before, you can paste graphs into Notepad, Paint, PowerPoint, etc. 
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V9R5 What’s New 

⚫ 3D Plot 

– The 3D Plot function allows you to draw a 3D graph by specifying the data for the X, 

Y, and Z axes. 

– It is now possible to view the value changes for 3 axes or draw the movement 

trajectory of markers and bodies in 3D space. 

– To draw a 3D Plot, follow the steps shown in the figure below. 
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V9R5 What’s New 

⚫ Export Data 

– RecurDyn Post offers the Export 

Data function similar to that 

provided in RecurDyn/Plot. 

– You can drag the desired data to 

the dialog box and save it in text 

format. 

 

 

 

– The number of significant digits can be 

set in [File]-[Options]-[General]. 

 

 

⚫ Campbell Diagram 

– Campbell Diagram offered in RecurDyn/Plot is also provided in RecurDyn Post. 

– RecurDyn Post provides a UI similar to that of RecurDyn/Plot and supports both 2D 

and 3D diagrams. 
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V9R5 What’s New 

Multi-Target Marker of MTT2D/3D Event Sensor 

Product MTT2D, MTT3D 

New/Improved Improved 

Location in User Interface MTT2D/3D tab → Sensor group → Event icon 

Location in Manual Toolkit > MTT2D → Specific Sensors → Event Sensor → Properties 

 

 

When using a marker as a target sensing entity in Event Sensor in MTT2D or MTT3D, it is now 

possible to select multiple markers. Multiple target markers for sensing can be selected through 

the newly added Marker List dialog box. 

 

 

  

Description 
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V9R5 What’s New 

Others 

Professional 

Added Friction to Planar Joint, Inplane Joint, and Screw Joint 

It is now possible to define friction for Planar Joints, Inplane Joints, and Screw Joints. 

 

 

Export Contact Pressure Contour Data of Rigid Body 

A function has been added to export the Contact Pressure results of contact between rigid bodies 

using Geo Surface Contact in CSV file format.  
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V9R5 What’s New 

MFBD 

Display of Damage Value Greater Than 1 

In Durability's analysis results, all Damage values greater than 1 were displayed as 1. However, it 

is now possible to display the damage values greater than 1 as their original values. 

 

Added Stop Function During Fatigue Calculation of RecurDyn/Durability 

When performing a calculation by clicking the Calculation button in the Fatigue Evaluation dialog 

box in Durability, it is now possible to stop the calculation by clicking the X button at the top right 

of the Progress bar. 

 

 

Control 

RecurDyn Can Be Set as Master When Simulink Type Is Selected in General CoSim 

When selecting the interface as a Simulink type in General CoSim, only Simulink could be selected 

as a master in the previous version, however it is now possible to select RecurDyn as the master as 

well. 
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V9R5 What’s New 

Toolkits 

EHD improvements 

⚫ Piston Lubrication 

– Piston Base Mesh Grid: You can create a mesh grid on the piston surface. At this time, 

because the mesh grid is generated based on the piston skirt, the number of mesh 

grids used for simulation can be minimized. This makes simulation speeds faster than 

before. 

– Non-Uniform Mesh Grid: The Piston Profile supports a Non-Uniform Mesh. You can 

define the Offset values in the Piston PatchSet's Nodes. After exporting the node 

positions as a rdp file, it is now possible to define and modify the offset values in the 

rdp file, and then import the rdp file again. 

 

ProcessNet 

ProcessNet 

⚫ Support for adding and modifying output list of Sheetbody in MTT2D 

⚫ Support for Custom View when using Animation Load 

 


